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What  Is CatBase?
CatBase is a fully functional relational database management system which has

been specially programmed to provide various publishing functions that are not normal-
ly found in a database. It is designed to make it easy for you to publish your catalogue,
directory, or similar type of publication in various ways, all from the same source.

We used to think of publishing as simply printing information on paper. Not any
more! Now we also need to make our information available over the Internet; to other
people in our offices via our office intranet; on CD; and in various other electronic for-
mats. CatBase enables you to do all of these things efficiently, accurately, quickly, and
easily.

With CatBase you:

Accumulate
Start by getting data into the database, either by entering it manually, importing it

from virtually any other source, or by scanning printed text using OCR software (cur-
rently, Macintosh only).

Update
Update the data as necessary, either manually or by importing an update file (for

example, you may want to update product prices using data from your accounts sys-
tem).

Communicate
If you have information on people or companies in the database you can communi-

cate with them directly  from the database via:
• Mail merge letters
• Faxes (Mac only, currently)
• Emails

Disseminate
Once the data is ready to publish, you can do so in any of the following formats:
• In Print:

QuarkXPress  documents
Multi-Ad Creator 2 documents (Mac only)
PageMaker documents
Microsoft Word documents
Any page layout or word processing program that can interpret

RTF tags

• Electronically:
HTML documents
Text files in various formats (tab- or comma-delimited)

• The Internet:
Run CatBase as a completely self-contained web server
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• Office Intranet:
Run CatBase as a completely self-contained Intranet server, enabling

everybody on  the office network to have access to the data.

Of course, you can also do all the things you would expect with a database, such
as:

• Reports
• Graphs & charts

The Demo Version
The Demo version of CatBase is a fully functional version of the program -- you can

do everything with it that you can do with the full version. However it is limited to 50
records per table.

System Requirements
CatBase runs on Windows 95, Windows NT, and Macintosh operating systems. It is

available in Single-User and Multi-User flavours. In a multi-user setup, the server can be
either Macintosh or Windows (NT is strongly recommended), and the clients can be any
combination of Windows and Macintosh.

How to Use This Manual
This manual is designed to give you an overview of what CatBase can do. It is

organised into the following chapters:

1. Introduction 
That’s what you are reading  right now.

2. Installation
This brief chapter describes how to install CatBase and start it up, and an overview

of the interface.

3. Publishing The Data
Who cares about how the data got into the database? Let’s see what CatBase can

do with it once it’s there! In this chapter we show you how to publish the information in
various ways. Look at the sections that are of particular interest to you:

3.1 Quark XPress
3.2 PageMaker
3.3 Multi-Ad Creator
3.4 RTF Documents 
3.5 HTML documents
3.6 Text Files
3.7 Web or Intranet Server
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4. How Does CatBase Do That?
In this chapter we take a look at how to set up CatBase to create the various pub-

lishing formats.

5. Using the Database
We take a look at the data entry screens and how to find and modify records.

6. Customising the Database
Here we show you how you can set up the database to suit your specific require-

ments.

7. Importing Data
An overview of the data importing facility.

8. Reporting and Communicating
How to create:
8.1 Quick Reports (columnar reports)
8.2 Charts
8.3 Labels
8.4 Mail shots
8.5 Faxes
8.6 Emails
8.7 Memos

9. Any Questions?
How to get additional information about CatBase

10. How to Order
Contact information and an order form.

11. Index

Conventions used in this Manual
The screen shots shown are generally taken on a Macintosh, so if you are using

Windows, your screens will look slightly different.
Most features work identically on both Mac and Windows; where there is a differ-

ence, an icon will be shown to draw your attention to that fact:

Mac Windows

You will be able to find more detailed information about CatBase in the Reference
Manual. This is provided in PDF document format on the CatBase CD, and is also avail-
able for downloading from our web site.

INTRODUCTION
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Installing CatBase
If you received a CD ...
1. Insert the CD into your computer’s CD drive.
2. Mac: Copy the CatBase folder onto your hard disk.

Windows: the Installer should start automatically. Follow the instructions.

If you downloaded the demo from our web site ...
You will have downloaded a compressed file onto your hard disk. Double-click on it

to install all the files.

And then ...
You should now have a folder called CatBase 4, which contains the following items:

INSTALLATION
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ITEM
The CatBase program --
Essential!

The data file -- Essential!

The plug-ins folder --
Essential!

The Web Site folder

Pictures used in the Demo

The Documentation folder

Spelling Checker
Dictionary

3rd Party Demos Folder

New Database

Examples folder

MAC
One file called CatBase 4.xx

PPC (“xx” representing the current
version number). This is for use on
PowerPC, G3 and iMac computers.

One file called CatBase 4.xx
68K. This is for use on other
Macintosh computers.

One file called Demo Data

A folder called Mac4DX

This folder is called HTML

A folder called Pictures

CatBase Demo Manual.pdf:
This document as a PDF file

Acrobat installer (required for
opening the documentation)

Reference Manual folder: this
folder contains the complete
CatBase reference manual as PDF
documents.

A file called Dictionary

Demo versions of other pro-
grams and plug-ins.

One file called New Database

Some files that are used as
examples in the Demo.

WINDOWS
Three files: 

Catbase4.EXE, 
Catbase4.4DC, and 
Catbase4.rsr. 

Two files:
Demodata.4dd and 
Demodata.4dr

A folder called Win4DX

This folder is called HTML

A folder called Pictures

CatBase Demo Manual.pdf:
This document as a PDF file

Acrobat installer (required for
opening the documentation)

Reference Manual folder: this
folder contains the complete
CatBase reference manual as PDF
documents.

A file called Diction.dic

Demo versions of other pro-
grams and plug-ins.

A folder called NewDatabase,
which contains two files.

Some files that are used as
examples in the Demo.

There are also a few other files
which must remain in the folder.



Everything labelled Essential in the CatBase folder is VITAL and must not be
removed from the folder. Also, you must not change the names of the plug-ins folder
(Mac4DX or Win4DX) and the HTML folder.

Starting CatBase 
To start CatBase, double-click on the CatBase icon (on Windows: choose CatBase

form the Start menu or doub;e-click on Catbase4.EXE).  (Note: if you are using
Windows and your system is not displaying file extensions, it’s the icon that looks like a
cube sitting on a cog).

If you see a dialogue asking you to select a data file, double-click on Demo Data
(Mac) or DemoData.4dd (Windows).

If you are using the Demo version of CatBase, you will see a message like this:

Click on the Demo Mode button.

You will then see the Password dialogue:

We have not set up any passwords in the Demo database, so just click on the Log
In button or press the Return key.

Click the mouse button anywhere on the screen, or press the Return key again, to
make the status window go away if it is still visible.

You’ll then see the main CatBase screen:
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There are two floating palettes visible: the CatBase options palette and the Screen
Selector palette (they may not be in exactly the same positions as shown in this illustra-
tion).

If either of the two floating palettes are not visible, you can show them by choosing
Options Palette or Show Screen Selector … from the File menu.

CatBase Options Palette
This palette provides access to the various functions and utilities in CatBase. All

options are also available by making selections from the menu bar, so you can choose
to be a button-pusher or a menu-chooser. If you feel that the Options palette clutters
up your screen, you can close it by clicking on its Close box.

Screen Selector
At the moment, you have only one window open, but as you work with CatBase

you will frequently have a number of windows open at once. The Screen Selector main-
tains a list of all open windows, so if the one you want gets buried, you can easily bring
it to the front by selecting it from the list on this palette.

You can tell CatBase whether or not you want either of these palettes displayed by
modifying the choices on the Preferences screen. To modify your Preferences, either
click on the Prefs button on the CatBase palette or choose Preferences from the
File menu.

INSTALLATION
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Let’s take a quick look at what’s on the menu.

File Menu

Options palette: Displays the CatBase options palette if it isn’t already dis-
played.

Import: Provides access to the Import Formats table for importing data.
Memos: Provides access to the Memos facility.
Preferences: Opens up the User Preferences screen.
Send Message: Lets you send a message to another CatBase user (multi-user

version only).
Send email …: Lets you send an email while you are using CatBase.
Show screen selector: Displays the Screen Selector palette if it isn’t already

displayed.
Save Database: Forces CatBase to flush all modified data from memory to disk.
Quit: Closes CatBase down. 

Edit Menu
Contains the usual editing functions such as Cut, Copy, Paste etc.

Data
This is the menu you will use most. It provides access to your data:

Companies: Provides access to one of the two main tables, the Companies
table. (Note: You can change the name of this table to anything that suits your needs;
see Chapter 6, Customising the Database, for more information).
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Products: Provides access to the other main table, the Products table. (Note: You
can change the name of this table to anything that suits your needs; see Chapter 6,
Customising the Database, for more information).

Product Details: Provides access to  the Product Details table. This table is
related (linked) to the Products table. See Chapter 5, Using the Database, for more
information.

Categories: Provides access to the Categories table. You can set up Categories
in a three-level hierarchy, and each Company or Product record can go into any num-
ber of Categories.

Contacts: Provides access to the Contacts table, which is related to the
Companies table. See chapter 5, Using the Database, for more information.

Export Style Sheets: Provides access to the Export Style Sheets table. Export
Style Sheets control the content and format of your data when you publish it. See
Chapter 4 for more information on Export Style Sheets.

Style Sheets: Provides access to the Style Sheets table. Working with Export
Style Sheets, Style Sheets control the formatting of your data when it is published.

H&Js: Provides access to the Hyphenation and Justification table, which is used in
Style Sheets.

Colours: Lets you define and create colours to use in your publications.
Email Accounts … Lets you set up your email account details (necessary if you

want to send emails from the database).

Admin Menu
This is where you go to perform database administration functions such as manag-

ing the web server and setting up the database:

Turn Web Server on: Tells CatBase to function as a Web Server.
Flush Web Cache: For use when the web server is running.
Web Floater: Displays the Web Server floating palette when the Web Server is

running.
Web response monitor: Logs incoming and outgoing requests and replies

when the web server is running.
Users: Lets you add new authorised Users to the database.
Delete Records from Database: This is where you go to actually delete

records that have been flagged for deletion.
Setup: Set various database preferences (as opposed to user preferences)
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Table and Field Setup: This is where you go if you want to change the names
of the Companies, Products, Contacts, or Product Details tables and their associated
fields, and specify which fields to display or hide.

Zap Table: Lets you  instantly delete ALL THE  RECORDS in a table. Very danger-
ous!

Lists: For managing the various lists that are used in CatBase.
Check Web for Update ... Checks our web site to see if a newer version of

CatBase is available.

OK, now let’s move on to the fun part ... publishing some data!
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The Demo Database
The Demo Database contains information about some computer and software sup-

pliers, and their products. We have used the Companies table for the basic company
information (name, address, phone numbers, etc.) and the Products table for informa-
tion about the products they sell. Each Company and Product has been put into one or
more Categories. Let’s just take a moment to have a quick look at the Categories.

Choose Categories from the Data menu (or click on the Categories button in
the Options palette). You will see the standard CatBase Search window:

This is “command central” for accessing the data in your database -- you’ll see this
window  whenever you choose a data item from the menu. From here you  add new
records or search for existing ones.

Click on All Records to see a list of all the Categories:
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PUBLISHING DATA

What, only two Categories?  No, of course not. Click on the Show Hierarchy
button to see how the Categories are set up:

The Categories are set up in a three-level hierarchy. Click on one of the items in the
Level One list, and the corresponding Level Two Categories will be displayed; click on a
Level Two category and the corresponding Level Three categories will be displayed  …
for example:

Each Company and Product record can go into any number of Categories on any
level. When the data is published, it can (optionally) be sorted by Category. 

Click on Done to close the Hierarchy window, and on Done again to close the
Categories window.
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PUBLISHING DATA

Publishing Data
The steps involved in publishing your CatBase data are as follows:
1. Set up one or more Export Style Sheets in the database. These describe what

information you want to include and how you want it organised and formatted.
2. Select the records you want to publish.
3. Tell CatBase which Export Style Sheet to use, and what the destination format

is (for example, a QuarkXPress layout, HTML documents, etc.).
4. Export the data to a text file.
5. Open up the text file in the destination program (XPress, web browser,

PageMaker, etc.)

In this chapter we will show you how to publish data from CatBase without going
into detail about how it all works. You will find an overview of how Export Style Sheets
and some other features work in later chapters; if you need more detailed information,
please refer to the relevant chapter in the Reference Manual. 
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PUBLISHING WITH QUARKXPRESS

3.1 Publishing with QuarkXPress
You will need to have a copy of QuarkXPress in order to try these examples.

3.1.1 XPress Example 1: Product Catalogue with Pictures
This example creates a colourfully illustrated product catalogue. 
To use this example, you will need to have a QuarkXtension called Xtags installed in

the Xtension folder in your QuarkXPress  folder. If you do not have a copy of XTags, you
will find a demo in the 3rd Party Demos folder. Simply run the Xtags installer and then
copy the XTags Demo into your Xtension folder (Quit XPress first if it’s already running).
XTags makes it possible for Quark to create and fill picture boxes automatically.

i. Choose Products from the Data menu, or click on the Products button on
the CatBase Options palette.

ii. When the Search Dialogue window appears, click on the All Records button.
You will then see a list of all the Product records in the database.

iii. Choose Export from the File menu. You’ll see the Export Dialogue:

The Export Dialogue shows a list of all Export Style Sheets that have been set up for
the selected table (Products, in this case), and a pop-up menu listing the various avail-
able Export Formats (publishing destinations).

iv. Choose Product Catalogue in the Export Using: list, and make sure that
XPress 3.x or 4.x is selected in the Export Format pop-up menu.

v. Click on OK.
You will then see a dialogue asking you to enter a name for the file to create.
The default name is Export (Export.xtg on Windows). Change the name if you
like, and make sure it is going to be saved into the CatBase folder, then click on
the Save button.

vi. CatBase exports the data from the database to your text file, and displays a
thermometer telling you how it is getting along.

vii. When CatBase has finished exporting the data, start QuarkXPress and create a
new document with a three-column text box. Save this document into the
CatBase folder. (It’s important that the document is saved at this point, and that
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it is saved into the CatBase folder, otherwise the picture importing will not work
correctly.)

ix. When the document is open, click in the text box and then choose Get Text
with Xtags from the File menu. (Note: If this menu option is not available, then you
have not installed the XTags Xtension.)

x. Locate the file you  just created and double-click on it.
Watch as the data is imported into the document, formatted, and the pictures are

placed on the page. (Note: If you are using the demo version of XTags, the import will
stop after 50 paragraphs.)

When it’s done, your screen should look something like this:

If the pictures did not appear:
i. Close the Quark document.
ii. Open up your CatBase folder and check that -

Your XPress document has been saves into the folder (not within another folder),
and

The Pictures folder is also in the CatBase folder (i.e., not within another folder)
In other words, the XPress document and the Pictures folder must both be in the

same folder together.
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Now for something a little more ordinary …

3.1.2 XPress Example 2: Product Information Table
In this example, we will produce a basic table containing information about products

listed in the database.

i. If you do not already have a list of Products on your screen, choose Products
from the Data menu, or click on the Products button on the CatBase Options palette,
and click on  the All Records button in the Search Dialogue window.

ii. Choose Export from the File menu.
iii. In the Export dialogue, select the Universal Product Info Table in the Export

Using: list, and make sure that Xpress is selected under Export Format.
iv. Click on OK, enter a name for the export, and click on Save.
When CatBase has finished exporting the data:
v. Create a new XPress document with a one-column text box.
vi. Click in the text box and choose Get Text ... from the File menu.
vii. Locate the file you  just exported from CatBase and click on it  ONCE.
viii. Make sure that the Include Style Sheets check box is selected in the Get

Text dialogue.
ix. Click on Open.
Your document should look  like this:

PUBLISHING WITH QUARKXPRESS
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PUBLISHING WITH QUARKXPRESS

3.7

The columns of information are the Product Name, Price, Discount Price, Supplier, and
Date Updated.

Notice how CatBase has handled various formatting tasks automatically:
1. The Disc. Price has been calculated as a 20% discount, and set in red.
2. The Supplier name is in green.
3. The Date Updated is in italics.
These formatting options are controlled by the Export Style Sheet (please see

Chapter 4 for more information on Export Style Sheets).

3.1.3 XPress Example 3: Company Details List
This example creates a list of Companies in the database, sorted by Country and,

within each Country, by company name.

i. Create a list of Companies by choosing Companies from the Data menu or
by clicking on the Copanies button on the CatBase Options palette, and then
clicking on all Records.

ii. Choose Export from the File menu.
iii. Select the Company Info by Country Export Style Sheet and make sure that

XPress is selected, then click on OK.
iv. Enter a name for the file and click on Save.
v. When CatBase has finished exporting, create a new XPress document with a

two-column text box.
vi. Click in the text box and then choose Get Text ... from the File menu.
vii. Locate the file you just created and click on it once. Make sure that the

Include Style Sheets check box is checked, then click on Open.
Your screen should look like this:



Notice how the country headings have been formatted, and that each one appears
only once. This is controlled by the Unique Group Entry attribute on the Country ele-
ment in the Export Style sheet (please see Chapter 4 for more information about Export
Style Sheets).

That’s it for our Quark demos. If you are interested in seeing how CatBase works
with other publishing destinations, please look at the other examples in this chapter.
Otherwise, we suggest that you proceed to Chapter Four to discover how CatBase
uses Export Style Sheets to control the formatting of your data.

PUBLISHING WITH QUARKXPRESS
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3.2 Publishing with PageMaker
You will need to have a copy of PageMaker in order to try these examples.

Versions of PageMaker prior to V. 6.5 supported the RTF text tagging format for
automatically formatting text, whereas V. 6.5 and beyond additionally support a more
sophisticated format including the automatic placement of in-line pictures. So it’s
important to make sure that you know which version of PageMaker you are using! If
you are using Version 6.5 or later, you will select the PageMaker 6.5+ choice for export-
ing data, and if you are using an earlier version, you’ll select the PageMaker 6.5-
choice.

3.2.1 PageMaker Example 1: Product Catalogue
This example creates a catalogue of products in the database -- with pictures if you

are using PageMaker Version 6.5 or later.

Important!
If you are using PageMaker Version 6.5 or later, you must make one  small change

in the database before trying this example:
i. Choose Export Style sheets ... from the Data menu and click on All

Records.
ii. Double-click on the Export Style Sheet called Product Catalogue to open it up.
You’ll see this screen:

ii. Click on the Preferences 1 tab. You’ll then see the first of two Preferences
pages. This page includes an area for PageMaker 6.5 or later:

PUBLISHING WITH PAGEMAKER
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iii. You need to tell CatBase where to find the folder that contains the pictures.
Click on the Select button, locate the CatBase folder on your computer, and
click on Select. You should end up with a pathname something like this (on a
Mac):

MacHD:CatBase 4.18:

On Windows, the pathname will be something like:

C:\Program Files\CatBase4\

The important thing is that you select the folder that contains the Pictures folder (the
Pictures folder should be in your CatBase folder).

iv. Press the Enter key on your keyboard twice to close the Export Style Sheet.

Now, to export the data:
i. Choose Products from the Data menu, or click on the Products button on

the CatBase Options palette.
ii. When the Search Dialogue window appears, click on the All Records button.

You will then see a list of all the Product records in the database.
iii. Choose Export from the File menu. You’ll see the Export Dialogue:

The Export Dialogue shows a list of all Export Style Sheets that have been set up for
the selected table (Products, in this case), and a pop-up menu listing the various avail-
able Export Formats (publishing destinations).

iv. Choose Product Catalogue in the Export Using: list, and select either
PageMaker 6.5- or PageMaker 6.5+ in the Export Format pop-up menu.

v. Click on OK.

PUBLISHING WITH PAGEMAKER
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You will then see a dialogue asking you to enter a name for the file to create. The
default name is Export (Export.txt on Windows). Change the name if you like, and make
sure it is going to be saved into the CatBase folder, then click on the Save button.

vi. CatBase exports the data from the database to your text file, and displays a
thermometer telling you how it is getting along.

vii. When CatBase has finished exporting the data, launch your copy of PageMaker
if it isn’t already running, and create a new two-column document.

viii. Make sure that Autoflow is ticked (under the Options or Layout menu)
ix. Choose Place from the File menu. 
x. Locate the file you just created and select it.
xi. Make  sure the Read Tags check box is selected.
xii. Click on OK.
xii. Click in the top left-hand corner of the document to place the text.
Watch as the data is imported into the document and formatted. 
When it’s done, your page should look something like this:

If you are using an older version of PAgeMaker, the pictures willl not appear.

PUBLISHING WITH PAGEMAKER
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You can globally change the formatting of any text by modifying the associated Style
Sheet.

3.2.2 PageMaker Example 2: Product Information Table
This example creates a basic table containing information about products listed in

the database.
i. If you do not already have a list of Products on your screen, choose Products

from the Data menu, or click on the Products button on the CatBase Options
palette, and click on  the All Records button in the Search Dialogue window.

ii. Choose Export from the File menu.
iii. In the Export dialogue, select the Universal Product Info Table in the Export

Using: list, and make sure that one of the PageMaker formats is selected
under Export Format.

iv. Click on OK, enter a name for the export, and click on Save.
When CatBase has finished exporting the data:
v. Create a new one-column PageMaker document.
vi. Choose Place ... from the File menu.
vii. Locate the file you  just exported from CatBase and click on it.
viii. Make sure that the Read Tags check box is selected.
ix. Click on OK.
x. When the text file has been loaded, click in the top left-hand corner of the docu-

ment to place the text.
Your page should look like this:
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The columns of information are the Product Name, Price, Discount Price, Supplier,
and Date Updated.

Notice how CatBase has handled various formatting tasks automatically:

1. The Disc. Price has been calculated as a 20% discount, and set in red.
2. The Supplier name is in green.
3. The Date Updated is in italics.

These formatting options are controlled by the Export Style sheet (please see
Chapter Four for more information on Export Style Sheets).

That’s it for our PageMaker demos. If you are interested in seeing how CatBase
works with other publishing destinations, please look at the other examples in this
chapter. Otherwise, we suggest that you proceed to Chapter Four to discover how
CatBase uses Export Style Sheets to control the formatting of your data.

PUBLISHING WITH PAGEMAKER
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3.3 Publishing with Multi-Ad Creator
You will need to have a copy of Multi-Ad Creator in order to try these examples (and

it is assumed that you know how to use it!).

3.1.1 Multi-Ad Example 1: Product Catalogue 
This example creates a product catalogue. Each product appears in its own text

box.

First of all:
i. Start up Multi-Ad Creator and create a new document..
ii. Create two Text Styles and name them whatever you wish. One will be used for

formatting the product names, and the other for the the product descriptions.
Select the font, style, etc. that you want to use for each of the two Text Styles.

iii. Create two Paragraph Styles and name them ProductName and Details (note:
no spaces in ProductName). Select the appropriate Text style for each
Paragraph Style.

Now, in CatBase:
i. Choose Products … from the File menu and click on All Records.
ii. In this example we do not want to export all the Product records. Select about

six records by holding down the Command key (Mac) or the Control key
(Windows) and clicking on individual line items. Once you have made a selec-
tion, choose Show Subset from the Search menu. You should then have a
list of only the Products you selected.

iii. Choose Export from the File menu. You will see the Export Dialogue:

The Export Dialogue shows a list of all Export Style Sheets that have been set up for
the selected table (Products, in this case), and a pop-up menu listing the various avail-
able Export Formats (publishing destinations).

iv. In the Export dialogue, select Multi-Ad Demo in the Export Using area, and
make sure that Multi-Ad Creator is selected in the Export Format popup.
Then click on OK.

PUBLISHING WITH MULTI-AD CREATOR
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v. Type in a file name for the export file and click on Save.
When the export is finished:
i. Go to the Multi-Ad Creator document that you created.
ii. Choose Import Text … from the File menu.
iii. Select the file you just exported from CatBase.
iv. Select the Break Text radio button and click on Place.
v. The Break Text window appears:

Your screen will probably look a bit different at first. There are three important
changes to make.

i. Select the At delimiter radio button in the Break text area and enter
[break] into the text area. The Break Text area should look like this:

ii. Select the Apply Tags radio button in the Format area.
iii. Select the Make array of blocks radio button, below the Break Text

area.
Now you can click on OK.

Multi-Ad Creator imports your text file and creates a new text block for each
Product. When it’s done, your screen should look something like this:
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Of course, yours will probably have different formatting selected for the product
names and descriptions.

Each Product has been placed into an individual text block, which can be moved
around and modified as necessary.

You can experiment with the various import options to obtain different effects. For
example, if you choose Place by Hand instead of Make array of blocks in the
Break Text dialogue, you can draw each text block individually as the text is import-
ed.

If you are interested in seeing how CatBase works with other publishing destina-
tions, please look at the other examples in this chapter. Otherwise, we suggest that you
proceed to Chapter Four to discover how CatBase uses Export Style Sheets to control
the formatting of your data.
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3.4 Publishing RTF Documents
The RTF (Rich Text Format) document format is a very versatile format that can be

interpreted by a  wide variety of word processing and page layout programs. For the
purposes of our demo, we will be using Microsoft Word.

3.4.1 RTF Example 1: Product Catalogue 
This example creates a product catalogue. 

i. Choose Products from the Data menu, or click on the Products button on
the CatBase Options palette.

ii. When the Search Dialogue window appears, click on the All Records button.
You will then see a list of all the Product records in the database.

iii. Choose Export from the File menu. You’ll see the Export Dialogue:

The Export Dialogue shows a list of all Export Style Sheets that have been set up for
the selected table (Products, in this case), and a pop-up menu listing the various avail-
able Export Formats (publishing destinations).

iv. Choose Product Catalogue in the Export Using: list, and select RTF in the
Export Format pop-up menu.

v. Click on OK.
You will then see a dialogue asking you to enter a name for the file to create.
The default name is Export (Export.RTF on Windows). Change the name if you
like, and make sure it is going to be saved into the CatBase folder, then click on
the Save button.

vi. CatBase exports the data from the database to your text file, and displays a
message telling you how it is getting along.

vii. When CatBase has finished exporting the data, start Word (or whichever pro-
gram you are using).

viii. Import the document into your program in the appropriate way. With Word (or
most other word processors), you will do this by choosing Open … from the
File menu, and then selecting and opening the document. With page layout
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programs, such as PageMaker, you must first create a new document and then
import the text into that document by choosing Place or Import Text, or
something similar, from the File menu (consult your program’s documentation if
you are not sure how to do this. Look in the index under “Importing text’).

Watch as the data is imported into the document and formatted!
When it’s done, your page should look something like this:

If your document looks nothing like this, and appears to be full of gobbledygook,
this is most likely because you do not have the RTF filter installed. Please check your
program’s documentation to find out how to correct this.

3.4.2 RTF Example 2: Product Price List
In this example, we will produce a basic table containing information about products

listed in the database.

i. If you do not already have a list of Products on your screen, choose Products
from the Data menu, or click on the Products button on the CatBase Options
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palette, and click on  the All Records button in the Search Dialogue window.
ii. Choose Export from the File menu.
iii. In the Export dialogue, select the Universal Product Info Table in the Export

Using: list, and select RTF under Export Format.
iv. Click on OK, enter a name for the export, and click on Save.
When CatBase has finished exporting the data:
v. Open the document into your program, as described in the first example,

above.
Your document should look like this:

Depending upon the dimensions of your document, you may need to fiddle around
with the tab settings a little to get the columns to line up correctly.

The columns of information are the Product Name, Price, Discount Price, Supplier,
and Date Updated.

Notice how CatBase has handled various formatting tasks automatically:

1. The Disc. Price has been calculated as a 20% discount, and set in red.
2. The Supplier name is in green.
3. The Date Updated is in italics.

These formatting options are controlled by the Export Style Sheet (please see
Chapter 4 of this document for more information on Export Style Sheets, or Chapter 7
of the Reference Manual for detailed information).
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That’s it for our RTF demos. If you are interested in seeing how CatBase works with
other publishing destinations, please look at the other examples in this chapter.
Otherwise, we suggest that you proceed to Chapter Four to discover how CatBase
uses Export Style Sheets to control the formatting of your data.

PUBLISHING RTF DOCUMENTS

3.20



3.5 Publishing HTML Documents
HTML documents are a very useful, and increasingly popular, method of distributing

information. The document consists simply of a text file containing special tags; since
the file is purely text, it is small and therefore suitable for sending by email, and it can be
interpreted by web browsers and an ever-increasing number of other applications such
as word processors and page layout programs. For our examples, we will use a web
browser to view our HTML documents.

3.5.1 HTML Example 1: Product Catalogue with Pictures
This example creates a colourfully illustrated product catalogue. 

i. Choose Products from the Data menu, or click on the Products button on
the Options palette.

ii. When the Search Dialogue window appears, click on the All Records button.
You will then see a list of all the Product records in the database.

iii. Choose Export from the File menu. You’ll see the Export Dialogue:

The Export Dialogue shows a list of all Export Style Sheets that have been set up for
the selected table (Products, in this case), and a pop-up menu listing the various avail-
able Export Formats (publishing destinations).

iv. Choose Products for web in the Export Using: list, and make sure that HTML
is selected in the Export Format pop-up menu.

v. Click on OK.
You will then see a dialogue asking you to enter a name for the file to create.
The default name is Export.html (Mac) or Export.htm (Windows). Change the
name if you like (but nothe file extension!), and make sure it is going to be saved
into the CatBase folder, then click on the Save button.

vi. CatBase exports the data from the database to your text file, and displays a
thermometer telling you how it is getting along.

vii. When CatBase has finished exporting the data, open up your favourite web
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browser (such as Netscape Navigator or Internet Explorer) and make sure that
you have a browser window open.

ix. Locate the file you  just created, click on it and drag and drop it onto your
browser window.

Watch as the HTML tags are interpreted and the page created!
When it’s done, your screen should look something like this:

If the pictures did not appear, that would be because the documents were not
saved into the CatBase folder, or the Pictures folder has been moved (the Pictures fold-
er must be within the CatBase folder).

If you scroll down to the bottom of the page, you will see this:

In the Export Style Sheet (on the Preferences 2 page), we specified that there
should be a maximum of four products per page, so CatBase has created a number of
pages and linked them together.

Additionally, CatBase has created an index page for the products that were export-
ed. To see it, locate the file called Index.html (or Index.htm), which you’ll find in the
same folder as the rest of the HTML documents, and drag and drop it onto your web
browser. You should see this:
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Clicking on any product name will open up the appropriate page.
For another example, export the products using the Universal Product Info export

(don’t forget to select HTML under Export Format). This will create a table like this:
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3.6 Exporting to Delimited Text Files
Sometimes you may need to transfer data from the CatBase database into a plain

(unformatted) file for transfer to another program (such as a spreadsheet), merging into
letters using your word processor, reporting, or for some other purpose. CatBase lets
you create delimited text files for this purpose.

3.6.1 Text File Example 1: Product List
This example creates a tab-delimited list of products and their prices.

i. If you do not already have a list of Products on your screen, choose Products
from the Data menu, or click on the Products button on the CatBase Options
palette, and click on  the All Records button in the Search Dialogue window.

ii. Choose Export from the File menu.
iii. In the Export dialogue, select the Universal Product Info Table in the Export

Using: list, and select Plain Text under Export Format.
iv. Click on OK, enter a name for the export, and click on Save.
When CatBase has finished exporting the data:
v. Open your word processing, spreadsheet, or page layout program and import

the document you just created into it. For example, to import it into an Excel
spreadsheet:

i. Launch Excel.
ii. Choose Open from the File menu.
iii. Locate your text file and double-click on it.
iv. Make sure that Tab is selected as the delimiter and import the file.
Your document should look like this:
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3.7 Web or Intranet Server
CatBase can function as a completely self-contained web server, and it’s remark-

ably easy to set up!
We have included an example web site with this demo. You can adapt it to your

own needs or create your own pages.
To try this example you will need to have two computers networked: one to act as

the server and the other as the user. The server will be the computer on which you have
installed the CatBase demo, and the user can be any other computer on the network
which has a web browser (such as Netscape Navigator or Internet Explorer) installed. If
you do not have access to a network, don;t despair, there is a way that you can run
both CatBase and your web browser on the same computer.

There are only a few steps you need to take to set up the web server.

i. Close any windows that  are open in CatBase.
ii. At the main screen, choose Setup from the Admin menu.
iii. Click on the Web Server tab at the top of the screen. You’ll then see this

page:

iv. There is a folder called HTML in your CatBase folder, and CatBase needs to
know exactly where to find it. Click on the Select button in the Site folder
area, locate the HTML folder within the CatBase folder, click on  it once to select
it (don’t open it), and then click on the Select button.

v. If you want to, you can personalise the site by filling in your company’s name
and other information in the Site Information area:
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The Logo name in this area is the name of a picture file of your company logo. If you
have one that you want to use, copy it into the Images folder which is within the HTML
folder, then click on the Select button in the Site Information area and locate
your logo.

iv. You’re now ready to run  your web server. Before you close this window,
though, click on the Update button in the IP Address area to find out what the
IP address of your computer is:

Make a note of that number.
vii. Close the window by clicking on the Close button at the bottom of the screen:

vii. Choose Turn Web Server On from the Admin menu.
Your web server is now running.
To check it out:
i. Start your web browser either on the same computer as CatBase is running or

on another computer on your network
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ii. Type the IP address of  the CatBase server into the Location area and press
Return. If you are running both CatBase and your web browser on the same
computer, use the following IP address: 127.0.0.1.

iii. Shortly you should see the CatBase home page:

If you selected your own logo graphic, that will appear in place of our CatBase Web
Server banner.

You can browse through a list of Companies or Products, search for a product by
category (click on the Search Us button), or send an email to people who are listed as
Users in the database by clicking on the Contact Us button.
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How Does CatBase Do That?
In this section we will take a look at the steps you take to tell CatBase how you

want your publication formatted.

To set up CatBase to publish data in print, as HTML documents, and as text files,
there are two steps to take:

1. Create Style Sheets
These are similar to the style sheets you create in your word processing or page lay-

out program.
2. Create one or more Export Style Sheets
These tell CatBase what data to include and how to sort and format it.

Style Sheets
Just like the style sheets you use in your page layout or word processing program,

the CatBase style sheets describe how you want your data formatted on a paragraph
level: the font, size, colour, indents, tab settings, and so on. However with CatBase, a
style sheet can be used for formatting text in more than one type of program. For
example, you might create a style sheet called CompanyName which you want to use
when you publish a catalogue in print, and also when you create HTML documents.
Let’s take a look at an example:

i. Choose Style Sheets from the Data menu, and click on All Records
when the Search dialogue appears. You’ll see a list of style sheets.

ii. Double-click on the style sheet called FiveColumnTable. The Style Sheet win-
dow opens:
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This style sheet is used in the Universal Product Info examples used in Chapter
Three.

Note: if the Font pop-up appears blank, that is because you do not have the font
that was originally selected for this Style Sheet installed on your computer. Select a font
that you like.

There are four “pages” of style sheets -- one for each type of program that will
accept style sheet information. 

Notice the three buttons at the bottom right of the screen:

The Tabs button has a + sign showing; this means that some Tabs have been
defined for this style sheet.

iii. Click on the Tabs button. A new floating window opens:

You can see that four Tab stops have been set up. 
iv. Close the Tabs window by clicking in its close box.
v. Click on the HTML tab at the top of the window. You will then see the HTML

page:
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Some of the basic information from the XPress page still shows (the font size and
colour, for example), but, since the formatting options for HTML text are somewhat lim-
ited, there’s rather a lot of empty space on this page.

vi. Click on the PM 6.5+ tab.
The PageMaker 6.5 or later page looks like this:
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Many of the options are the same as the XPress page, but there are some differ-
ences. The Text Box button is absent, for one thing, because this feature is not sup-
ported by PageMaker (for the purists: it is not supported natively by XPress, either, but
is implemented by way of an Xtension called Xtags).

vii. Close the Style Sheet window by clicking on the Save button or press-
ing the Enter key on your keyboard.

viii. Click on the Done button, or press Enter again, in the list of style sheets to
close that window.
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Export Style Sheets
This is what CatBase is really all about! Export Style Sheets are where you go to

control the way your publication will look: what data it will include, and how that
data will be organised, sorted, and formatted.

Let’s dissect an Export Style sheet to see what makes it tick.
i. Choose Export Style Sheets from the Data menu and click on All

Records in the Search Dialogue screen.
ii. Double click on the Universal Product Info Table to open it up. You’ll see this

screen:

Each Export Style Sheet is made up of one or more Paragraphs, and each
Paragraph is made up of one or more Elements.

To help make the logic of this clear, let’s have a quick reminder of what data export-
ed using this Export Style Sheet looks like:

4.5

EXPORT STYLE SHEETS



There is one Paragraph of information for each record (each record being, in this
case, one Product).

The table consists of five columns of information; remember that in the
FiveColumnTable style sheet there were four tab stops, which organise the table into
neat columns. Each “column” is a piece of data from the database or, in Export Style
Sheet-speak, one Element in the Paragraph.

iii. Double-click on the Info paragraph  to see the Elements that make up this
Paragraph:

There are five columns (fields) of data in the table, and each one is separated by a
Tab character to make the columns line up.

iv. Double-click on the first Element, the field Product Name. This opens up the
Element screen:
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There are seven types of Element, and they can be used in any combination, in any
order, to build up Paragraphs. Each Element type is briefly described below:

Field: The contents of a field in the database.
Text: Some text that you enter (for example, the word “Phone:”)
Formula: A formula that lets you tell CatBase how to make choices about what

data to include, and/or how to format it. For example, you can tell CatBase to
include a “New Product” message if a product has been added to the database
since a certain date.

Punctuation: A special character such as a Tab or a page break.
Calculation: The Calculation Element lets you tell CatBase to perform mathemati-

cal operations on numeric fields, for example to markup or discount prices.
Picture: Include a picture for each record
Relation: This Element type lets you grab information from a related table. For

example, if you are exporting Company information, you can use a Relation to
gather information about all Products that belong to each Company. For an
example of an Export Style Sheet that uses a Relation, see the Cos & Prods for
Web example.

v. Click the Cancel button to close the Element window without saving
any changes you may have made. You should now be in the Paragraph screen
which shows the list of nine Elements.

Remember that when the data is exported, some of the columns have special for-
matting applied. For example, the Company Names appear in green. How is this
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accomplished, you wonder! This is how ...
vi. Double-click on the seventh Element, the field Company Name.
vii. Click on the Preferences tab at the top of the screen. The Preferences page

looks like this:

viii. Click on the Text Format button. You will see the Character Formatting win-
dow:

Note: If no font is selected in your version, that’s because you do not have Helvetica
installed. Click on the pop-up menu of fonts and select one from your system.

Green has been selected as the colour for this Element.
ix. Click on Cancel to close the window.
While we’re here, let’s have a look at the other options on the Preferences page:
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Omit Paragraph if this Element is blank: Useful for situations such as addresses,
when you don’t want an empty line to appear if (for example) a company does not have
a fax number.

Index this Element: Adds an Index entry when the data is exported, if the
selected export format supports indexing (requires an XTension for use with
QuarkXPress). When used with HTML exports, this option will create a document called
Index.html (Mac) or Index.htm (Windows) containing references to the appropriate page
for each entry.

Table of Contents Entry: Adds a TOC entry when the data is exported, if the
selected export format supports it (RTF and PageMaker).

Unique Group Entry: This tells CatBase to include repeated information only once.
Very useful for (for example) creating subheadings of country names; for an example,
see the Company Info by Country XPress example.

Table Heading: The heading that will appear at the top of the column when data is
exported into an HTML table.

Click on the Cancel button a few times to close the export style sheet.

In the Universal Product Info Table example, there is just one Paragraph containing
nine Elements. Browse through some of the other Export Style Sheets to see how the
other example exports shown in Chapter Three have been set up.

You will find a detailed description of Export Style Sheets in Chapter 7 of the
Reference Manual.

If you want to try setting up an Export Style Sheet for your project, and you are not
sure how to go about it, please send us an email or fax describing what you are intend-
ing to achieve (ideally, with a sample layout), and we will help you to set it up. Our con-
tact information is shown in Chapter 10.

In the next chapter we will take a look at adding new records and searching for
existing ones.
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5.1

USING THE DATABASE

Using the Database
In this chapter we will show you how to create new records, how to find existing

ones, and what’s on the data entry screens.

Creating New Records
To add a new record to the database, you simply choose the table to which you

want to add a record, and then click on the New Record button in the Search
Dialogue window. For example, to create a new Company record:

1. Choose Companies … from the Data menu, or click on the Companies but-
ton on the CatBase Options palette.

2. When the Search Dialogue Window appears, click on the New Record but-
ton.

A new record is created. For the Companies table, it looks like this:

The information is organised into fields; each field contains a specific type of data,
such as a company name or phone number. It’s important for each piece of data to be
stored in the appropriate field, as this will make it possible to search, sort, and export
your data in certain ways. For example, by putting each company’s phone number into
the Phone number field, you will be able to search for a company by its phone number,
to find all companies in outer London by searching for phone numbers that begin with
0181, to precede phone numbers with the text “Tel: “ when they are published, and so
on.

You can change the names of the fields if you wish, and you can tell CatBase not to
display fields that you are not using, so as to prevent data from being entered into



unused fields by mistake and to un-clutter the screen. This is done by choosing
Database Setup from the Admin menu, and is described in more detail in Chapter
6.

Notice the box containing a group of buttons at the bottom of the screen:

The top row of buttons are the record navigation buttons. If you have just created a
new record, or if you are looking at the first or last record in the list, some or all of the
buttons in the top row will be dimmed. When you have found a selection of records and
have opened one, you can use these buttons to move through the list:

Go to the first record in the list.

Go to the previous record.

Go to the next record.

Go to the last record in the list.

The bottom row of buttons each have special functions:

Scan text and convert using OCR (requires a suitable scanner
and TextBridge OCR software).

Close the record, saving any changes that were made.

Close the record, but don’t save any changes that were made.

There are six “pages” of information for the Companies table, and these are
accessed by clicking on the tabs at the top of the window:

You click on these tabs to move among the different “pages” of the record. 
Following is a brief description of what’s on each page; you will find a detailed

explanation in Chapter 3 of the Reference manual.
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Address page
Here you’ll find fields for basic company information such as their address and tele-

phone numbers.
Categories page
On this page you can specify which Categories the company should be listed under

(if appropriate), and there are two “Notes” fields for storing descriptive information
about the company.

Contacts/Memos Page
On this page you can keep track of any number of Contacts for each company, and

set up Memos. Additionally, you will find information about  when the record was creat-
ed, and by whom, and when it was last modified, and by whom.

Picture Page
Here you can specify the name and location of a picture to be used when this com-

pany’s information is published (a logo, for example).
Info Page
There are a number of fields on this page for storing various different pieces of infor-

mation for the company.
More Info Page
This page contains some more fields for miscellaneous information.

Entering Data
Type the information you want to save for each record into the appropriate field, and

press either the tab or the Return key to move on to the next field.
When you have put all the necessary information into the record, click on the Save

button to close the record and save the changes you’ve made.

If you do not want to save the changes you have made, click on the Cancel button
instead .

Searching for Existing Records
There are two ways to find records in the database, both accessed from the Search

screen.
Quick Search
To search by one of the most commonly-used criteria (Company or Product Name,

for example), you select a field from the pop-up menu that appears on the Search
Dialogue and type in the search criteria. For example, to search for a company by
name:

1. Choose Companies … from the Data menu. You’ll see the Search Dialogue
Window:
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There is a pop-up menu in the middle of the screen, and Company Name is select-
ed as the default, as that is most likely to be the field you will search on.

2. Type the name of the company you want to find into the text area. Note that you
don’t have to type in the complete name; you can just type the first part, and
CatBase will find all records that start with that text. 

3. Click on the OK button or press the Enter key on your keyboard.
For example, in our Demo database,  if you type “cat” (without the quote marks, of

course), and then click on OK, CatBase will find the record for CatBase Software Ltd.

Detailed Search
You can search on any field, or any combination of fields, in the database. To do

this:
1. In the Search Dialogue window, click on the Search Editor button.
You’ll then see the Query Editor:
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In the middle of this screen is a list of the fields in the table that you are searching.
Note that the field list in your database may be different to the one shown here, as you
can change the names of the fields to suit your needs (changing field names is
explained in Chapter Six).

For example, suppose you want to find all companies in the UK.
1. Scroll down in the list of fields until you come to Country and click on Country

once.
2. Click in the Value text editing area and type in “UK” (without the quote marks).
The Query Editor should now look like this:
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3. Click on the Query button.

CatBase finds all the companies in the UK and lists them.

You will find a more detailed description of the Query Editor in Chapter 4 of the
Reference Manual.

Having found one or more records, double-click on one of them in the list to open
the record up.

In the next chapter we will show you how you can customise your database for your
publishing project.
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Customising the Database
We have set CatBase up with four basic tables to maintain your data:

Companies
Contacts
Products
Product Details

You can change the names of these tables if you wish -- for example, if you are
planning to produce an association membership directory, you might want to change
the name of the Companies table to Members.

These tables are linked together in the following ways:

Any number of Contacts can be linked to each Company.
Any number of Product Details can be linked to each Product.
Any number of Products can be linked to each Company.

In database terminology, the link between each two files is called a relation. The
advantage of this setup is to make it easy to create publications that combine informa-
tion from two or more related tables. For example, you may want to create a directory
showing each Company and, under each company’s information, a list of all of its con-
tacts. Or perhaps you want to publish a catalogue showing each product, along with its
supplier (Company) details.

You may find that you need to use only one of these tables, or all of them. It doesn’t
matter; you can just use the tables and fields that you need.

Each table is made up of a variety of different fields, each of which can contain a
certain type of data -- text, numeric, date, time, Boolean, or picture. There’s a very
good reason for making each field a certain type. If you keep date information in a Text
field instead of a Date field, you won’t be able to do queries such as “Find all the people
who have not contacted us since January” or to sort modified records by the date that
they were modified. If you keep price information in a text field instead of a numeric
field, you won’t be able to get the database to automatically mark up or discount prices
when the data is exported. Each field has been given a name, but in order to be flexi-
ble, many of the field names are somewhat droll, such as “P 21”. Fortunately, you can
change each field name to something more meaningful to you.

Changing Table and Field Names
To change the table or field names, choose Table and Field Setup… from the

Admin menu  (if you cannot see the Admin menu, you’ll need to Quit and start up
the database again, this time logging in as the Administrator). You’ll see this screen:
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There are four pages -- one for each of the modifiable tables (yours may already
have been modified, in which case, the field or table names may not be the same as
those shown here).To change a table name, simply type in the name you want to use in
the Table Name: field.

The list of fields is divided into five columns:

Original Field Name
This column shows the name with which the field was originally christened. You

can’t change these names -- they are there for reference.

Field Name to Use
This is the field name that you want to use. To change one, click on the name you

want to change, and edit it as you would edit text in your word processor.

Type and Size
These columns tell you what type of field it is, and (if it’s a String type of field), what

length it is. A word of explanation about text fields: There are actually two types of Text
field: Text and String. A text field can contain a large amount of text (up to 32,000 char-
acters), and it may contain Return characters. It cannot be indexed. A String field is a
maximum of 80 characters in length, and it can be indexed (indexing a field means that
searching and sorting on that field will be much faster when you have a lot of records in
the database). So it’s important to make sure that you use the appropriate type of field.

Similarly, numeric fields come in three flavours: Integer, Long Integer, and Real. 
An Integer field can hold whole numbers in the range -32000 to +32000.
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A Long Integer field can hold whole numbers with no limitations on their value.
A Real Number field can hold any number, including decimals.

Typically, you would use an Integer field for information such as Sort Order, when
you know that there will never be more than 32000 items to sort. You would use a Long
Integer field for larger values such as companies’ total annual sales, when the figure
could easily get into the millions but it will always be shown in whole numbers. You
would use a Real number field for other types of numbers, such as prices. If in doubt,
use a Real number field.

Boolean fields hold Yes/No or True/False information.

Show on Screen
This is where you tell CatBase whether you want each field to be shown on the

screen or not. The default is “Yes” for every field; to hide a field, click on the “Yes” for
that field. The display will change slightly:

Click in the check box to un-tick it. 

You can click in the column heading to sort the fields by that column. For example,
click in the Type heading to sort the fields according to their type.

When you have made whatever changes you want, click on the Save button
to close the screen and put your changes into effect.

You will find more information about changing table and field names in  Chapter 2 of
the Reference Manual.

General Preferences
There are various general database preferences that you can change.
Choose Setup from the Admin menu, and you will see this screen:
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There are various options on this screen -- we’ll just cover some of the important
ones briefly here.

Categories
Product or Company Category required: If either of these boxes are checked, you

will not be able to save a Company or Product record unless at least one Category has
been selected for that record.

Year 2000
CatBase is fully Year 2000 ready. You can select a “pivot year” for use in data entry -

- this works as follows: Let us suppose that your Pivot Year is 50. During data entry, if
you type in “1/1/51”, this will be interpreted as 1/1/1951. If you type in a date of 1/1/48,
it will be interpreted as 1/1/2048. This works only in Date type fields! If you type a date
into a text field, it will be simply text.

The Web Server page is covered briefly  in Chapter 3, and the Web Server
(advanced) page is not covered in this introductory manual. You will find detailed infor-
mation about the Web Server in Chapter 6 of the Reference Manual.

Setting User Preferences
Each person  who uses the database can set their own  Preferences. To set up a

new User record, choose Users from the Admin menu and click on the New
Record button when the Search  Dialogue appears.

The Users screen contains a set of Preferences check boxes:
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:

Present Memos on Startup
If this option is selected, each time the user logs on to the database, it will search

for his/her current Memos and display them.

Show Category Selection Palette
If this option is selected, whenever the user modifies a Company or Product record,

a floating palette will appear, from which he may select categories to assign to that
record.

Can receive web messages
If you are planning to use your database as an internet or intranet server, users with

this option selected will appear on a pop-up list of people to whom messages can be
sent.

Spell Check Notes / Product Descriptions
Select one or both of these options if you want the spelling checker to kick in when-

ever the Notes field in the Company table, or the Description field in the Products table,
is modified.

Show main palette on startup
If this option is selected, the CatBase Options palette will appear every time the user

logs on to the database.

Show screen selector on startup
If this option is selected, the Screen Selector floating window will appear when the

user logs on to the database.

Most of these options can be changed at any time by the user, by choosing
Preferences from the File menu at the main CatBase screen or by clicking on the
Preferences button on the CatBase Options palette..
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Importing Data
CatBase provides an easy way for you to import data into the database from some

other source, such as another database or a spreadsheet.
To see how this feature works, choose Import ... from the File menu and click

on All Records in the Search Dialogue window, then double-click on Fixed-length
test. Shortly you will see the Import screen:

This example has been set up to import a file containing fixed-length data fields:
there are a set number of fields, and each field has a set number of characters, padded
with spaces, as follows:

Company Name 70 characters
Extra Field 5 characters: this is a field that we want to ignore
Co 10 10 characters: a number 

Before importing the file, it’s always best to make sure that the fields are set up cor-
rectly. 

Click on the Select a File button. CatBase will ask you to select the file you are
going to import. You will find a file called CompanyUpdate in the Examples folder within
your CatBase folder; locate this file and double-click on it.

Shortly the Sample Import text area will change:
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The screen shows the first five records from the import file. The Extra Field column is
empty because by naming it Extra Field, we have told CatBase to ignore it.

Click on the Updates tab at the top of the screen. The Updates page looks like
this:

We have indicated that, for this import, we want to update existing records rather
than create new ones. The Key Field is Company name; this is the field that will be used
to match up import data to existing data. The only field that is going to be updated is
the Co 10 field, which contains some numbers.

Click on the Main tab to go back to the first page.
Now click on the Import Now button to start the importing process.
CatBase imports the records, displaying a thermometer to indicate its progress, and

when it has finished it displays a list of all the modified records. If you open up any of
those records you will see that the field Co 10 (on the Info page) now contains a num-
ber.
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Reporting and Communicating
In addition to publishing your CatBase data, you can  produce reports, graphs, and

labels, and you can also communicate by way of mailshots, emails, and faxes directly
from the database.

8.1 Quick Reports
Quick Reports provide an easy way to produce a basic columnar report. For exam-

ple suppose you want to print out a list of all products and their prices, sorted by prod-
uct name. This is how to do it:

(Note that in your data file, the name of the Products table may have been changed.
It’s the second item under the Data menu).

i. Choose Products from the Data menu and click on All Records in the
Search window.

ii. With the list of Products on your screen, choose Quick Report … from the
File menu. The Quick Report Editor looks like this:

To create your report, you simply drag and drop fields from the field list into the edit-
ing area.

We want our report sorted by Product Name.
iii. Scroll down in the list of fields until you find Product Name.
iv. Click on Product Name, hold down the mouse button, then drag and drop

Product Name into the Sort List area.
v. Product Name appears in both the Sort List area and the editing area.
vi. Drag and drop the field Price Numeric from the list of fields into the edit area, to
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the right of the Product Name column.
vii. Drag and drop the field Price Description into the edit area, to the right of Price

Numeric.
Now your Quick Report should look like this:

You can let CatBase try to figure out how wide to make each column,but this isn’t
the best solution. Instead:

1. Choose Page Setup from the File menu and choose the appropriate paper
size.

2. With the Price Description field still highlighted, click on the Automatic check
box in the Column area to de-select it. Now you will be able to resize the col-
umn: move the mouse pointer so that it is at the intersection of column and its
heading. It should change to a double-sided pointer; move it left or right to
make the column wider or narrower. Make this column a bit narrower.

3. Select the other two columns in turn, deselect the Automatic check box,
and make the Price Numeric column narrower and the Product Name column
wider.

The width of the page is marked by a vertical red line -- if you can’t see it, you can
make the window bigger by clicking on the bottom  right-hand corner and dragging it.

When you have set up the columns, choose Print from the File menu to print
your report.

8.2

QUICK REPORTS



8.2 Charts
You can produce a variety of charts from your database. As an example, we will cre-

ate a chart showing the number of products listed for each supplier.
i. Choose Products from the Data menu and click on All Records in the

Search window.
ii. Choose Chart … from the File menu. You’ll see the colourful Chart Wizard:

Like it says at the bottom of the window ... you need to select some data.
iii. Click on the Data selection tab.
iv. If it isn’t already selected, choose Products from the Source Table popup.
v. Drag Company Name from the list of fields and drop it into the Category (X Axis)

area.
vi. Click on the Formula… button, type in the number 1, and click on OK.
vii. Click on OK.
Your chart is drawn. It should look something like this:
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You can experiment with different chart types by using the menu options.

You will find a more detailed description of the Chart Wizard in Chapter 5 of the
Reference Manual.
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8.3 Labels
It’s easy to create labels using CatBase.
i. Choose Companies from the Data menu and click on All Records in the

Search window.
ii. Choose Label from the File menu.
iii. When the Order By window appears, find Company Name in the list of fields,

and drag and drop it into the Ordered by area. Click on the Order By button at
the bottom of the screen.

iv. You’ll then see the Label Wizard:

To create the label, drag and drop fields from the field list onto the label area. Here’s
an example:

Notice that on the fifth line, two fields have been joined together. This is accom-
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plished by dropping additional elements onto an existing element. The Label Wizard will
intelligently concatenate the data together.

You can select fonts, sizes, and so on for each line.

v. Click on the Layout tab. The Layout window looks like this:

This is where you can choose the size of the labels, how many are on the page, and
so on.

You can save your label setup by clicking on the Save button.

The Label Wizard is described in more detail in Chapter 5 of the Reference Manual.
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8.4 Mailshots
Need to send a letter to each company in the database? No problem -- use Quick

Letter!
(Note: This feature uses the optional word processor plug-in, 4DWrite. We have

included a demo version so that you can try it out.)

i. Choose Companies from the Data menu and click on All Records in the
Search Dialogue window.

ii. When you have a list of Companies on the screen, choose Quick Letter from
the File menu. You’ll see the Quick Letter window:

This window has its own menu bar, which offers the usual word processing features
plus some extra goodies.

Under the Database menu you will find some options that enable you to merge
data from the database:
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For example, to merge the Company Name into your letter:
i. Choose Insert Field … from the Database menu. 
ii. Choose Companies from the pop-up list of tables. A list of fields in the

Companies table appears. (NOTE: In the current version of 4DWrite, there is a
bug which means that the original database field names appear in this list
instead of the field names that have been specified in the Database Setup
screen).

iii. Double-click on Company Name in the list of fields.
The window closes and you will see some little markers in your letter: . If you

choose Show References from the Database menu,  it will show
the actual field name.

We have set up an example letter; you will find it in the Examples folder. To open it,
choose Open … from the File menu in the Quick Letter window. Open the Examples
folder (which should be in your CatBase folder) and double-click on Example Letter.

Quick Letter is described in detail in Chapter 5 of the Reference Manual.
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Faxes

Currently (Version 4.18), this feature is available for Macintosh only.  

In order to use this feature, you will need to have the following installed on your
Macintosh:

i. A suitable faxmodem 
ii. FaxExpress software 
iii. 4DWrite word processing plug-in
Please contact us if you require more details.

Assuming that you have fax numbers stored in your database, you can easily send
one or hundreds of faxes. 

i. Choose Companies from the Data menu  and click on All Records in the
Search Dialogue window (or search for a selection of Companies to send faxes
to).

ii. With a list of companies on the screen, choose Edit and Send Faxes …
from the File menu. You will see the Search Dialogue window again; click on
All Records.

You’ll see the Fax Editing window:
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(If there is more than one fax format in your database, you’ll see a list of them; dou-
ble-click on one to open it up.)

This window consists basically of a Quick Letter editing area in which you can add
text and pictures, and merge data from the database.

To send the faxes, simply click on the Send Faxes Now button.
CatBase then creates all the faxes and sends them to the Fax Express spooler.

Depending on how you have set up Fax Express, the faxes will either be sent immedi-
ately or stacked up for sending later (after 6pm, for example).

If CatBase comes across any records which do not have a fax number, it will let you
know this when it has finished sending all the faxes and you will have the opportunity to
view a list of those companies.

Sending faxes is described in detail in Chapter 5 of the Reference Manual.
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8.6 Emails
It’s the modern way to communicate ... and with CatBase you can do it in a flash.

If you want to try this feature, don’t forget to create some Company records with
your own data first! You must select one of the Email fields on the Company screen for
entering the email addresses.

First, you must set up your email account.
i. Choose Email Accounts … from the Data menu and click on New

Record. The Email Account window looks like this:

Note: on Windows the Read from Internet Config button is not visible.

ii. Complete the fields with your information. If you have an Internet Config file set
up (Mac only), you can click on the Read from Internet Config button
and most of the fields will be filled for you. 

The completed fields should look something like this:
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iii. Save the record by clicking on the Save button .
You will see another new Email Account record; click on the Cancel button to get rid

of it.
iv. Now choose Companies from the Data menu and find the companies to

which you want to send emails. If you want to really send some emails, create a
few new Company records by clicking on the New Record button in the Search
Dialogue window, and type the appropriate email address into one of the
Internet fields (be sure to use the same field in every record).

v. With a list of Companies on the screen, choose Send Email … from the File
menu and click on the New button. You’ll see this window:
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vi. Give this email a Name.
vii. Select the Bulk Mail radio button, and select the email field that you have

used from the pop-up menu.
viii. Select the appropriate email account  from the Send via: pop-up, if it isn’t

already selected.
ix. Type in the subject and the message you want to send.
x. Click on Send Now.
CatBase sends your emails, letting you know its progress.
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Memos
Memos are a useful tool for keeping track of things you need to do. For example,

you may want to remind yourself that a particular record will need to be updated in
three months’ time because a new version is being prepared.

To set up a Memo, you open up the appropriate Company or Product record, go to
the second (Companies) or third (Products) page, and add a new Memo. 

i. Choose Products … from the Data menu and click on All Records.
ii. Double-click on any record to open it up.
iii. Click on the Memos/Other tab. You will  then see the third page, on which is

the Memos area:

iv. Click on the Add button. A new Memo opens up:
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v. Type a comment into the Comment field.
vi. Enter today’s date into the Followup Date field. (Normally, of course,  you would

enter a followup date of sometime in the future, but for demonstration purposes, let’s
use today’s date for now).

vii. Type a short summary of the memo into the Key field.
viii. Enter a contact name into the Contact field, or click on the Lookup button to

select from a list of contacts for the company.
Your Memo should look something like this:

If you select the  Public radio button, anybody using the database will be able to
see the Memo; otherwise, only you will be able to see it.

ix. Click on the Save button or press the Enter key to save the Memo.
It will now appear in the Memos area:

Next time you open that record, the Memo will appear here if you are its Owner (if
it  has been flagged as Private) or whenever anybody opens the record (if it is Public).

You can also search for memos whenever you are using CatBase by choosing
Memos … from the File menu.
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Any Questions?
We hope that this brief manual has given you a good overview of what CatBase can

do, and answered most of your questions about the program. However, if you need to
know more about a particular feature, how to set the database up, or if you would like
to find out if we can customise CatBase to do  some special task for you, please con-
tact us by one of the following methods:

Telephone: 0700 CATBASE (0700 2282273)
(From outside the UK: + 44 700 CATBASE

Fax: 01920 877917
(+ 44 1920 877917 from outside the UK)

Email: info@catbase.com

Mail: FREEPOST SG455
Ware, Herts. SG12 8BR

or from outside the UK:
50 The Maltings
Stanstead Abbotts
Herts. SG12 8HG
UK

On the following page you will find a handy enquiry form, which you can either fax or
mail to us.
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ENQUIRY FORM

FROM: ___________________________________________________________________________

COMPANY NAME: ___________________________________________________________________

ADDRESS : _________________________________________________________________________

_________________________________________________________________________________

PHONE: _______________________________      FAX: ____________________________________

EMAIL : ___________________________________________________________________________

PLEASE SEND ME A CATBASE DEMO CD

PLEASE HAVE A TECHNICAL REPRESENTATIVE CONTACT ME

I HAVE THE FOLLOWING QUERY REGARDING CATBASE:

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

(USE ANOTHER SHEET IF NECESSARY )

PLEASE TELL US HOW YOU HEARD ABOUT CATBASE:

_________________________________________________________________________________

NOW ... FAX THIS FORM TO CATBASE SOFTWARE LTD. AT 01920 877917 (+44 1920 877917)
OR ... POST IT TO OUR FREEPOST ADDRESS : FREEPOST SG455, W ARE, HERTS. SG12 8BR

(FROM NON -UK ADDRESSES :   50 THE MALTINGS , STANSTEAD ABBOTTS, HERTS. SG12 8HG)
OR … SEND US EMAIL TO info@catbase.com  VISIT OUR WEB SITE AT www.catbase.com



CatBase LE: £395 (1,000 records per table) .................................... ____________

CatBase Single-User: £695................................................................ ____________

CatBase Multi-User -- 2 Workstations: £1,795 .................................. ____________

CatBase Multi-User -- ___ Workstations (CALL us for price) ............ ____________

XTags (picture import Xtension for QuarkXPress): ___ @ £199: ...... ____________
Indextension (Indexing Xtension for QuarkXPress): ___ @ £99: ...... ____________
4DWrite (word processing plug-in; necessary for composing emails, 

faxes,  and mailshots in CatBase): ___ @ £95: ................ ____________
Fax Modem + FaxExpress software: £150

(Macintosh only) ............................................................ ____________
FaxExpress Software Only (plug-in for sending faxes;

Macintosh only; suitable modem required): £50 ................ ____________

Subtotal: ............................................................................................£ __________

Add VAT at 17.5% (UK and EU addresses): ....................................£ __________

Delivery: UK addresses: .................................................................... F R E E!
Non-UK Addresses: Airmail: £20 ........................................£ __________

Courier: £50 ........................................£   __________

Total: ..................................................................................................£ __________

Payment Details         All prices quoted are in £ sterling
Cheque Enclosed  Charge my:      Visa        MasterCard       Diners Club        BarterCard

Card Number: _________________________________ Expiry Date: ____________

Signature:       _________________________________

Name: ________________________________________________

Company: ____________________________________________

Address: ______________________________________________

____________________________________________________

Telephone: __________________ Fax: ________________ Email: _____________________

IMPORTANT!!!!!
I will be running CatBase on:         Macintosh             Windows 95/98        Windows NT
Note: For CatBase Multi-User, you need to specify the server operating system; the workstations can be any
combination of Mac and Windows 95/98/NT. Windows 95/98 is not recommended for a server.

CatBase Software Ltd. FREEPOST SG455, Ware, Herts. SG12 8BR
(50 The Maltings, Stanstead Abbotts, Herts. SG12 8HG UK)

Fax: 01920 877917 (+44 1920 877917)   Phone: 0700 CATBASE (0700 2282273) Email: sales@catbase.com

CatBase Order Form
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